Degraded performance - Express Sign API

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 13:03 CET

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted Jan 26, 2026 - 12:34 CET

Investigating

We are currently observing degraded performance with the Express Sign API, and are currently investigating the issue.
Posted Jan 26, 2026 - 12:27 CET
This incident affected: Express Signature (Signature API).