Outage - Multiple methods

Incident Report for Signicat

Resolved

This incident is resolved. The root cause is not yet determined, but we are working with our providers to find the exact cause. We are also working on another mitigation on our side, in the event this issue appears again.
Posted Mar 17, 2026 - 17:17 CET

Monitoring

Our services are operational, but we are continuing to monitor closely.
Posted Mar 17, 2026 - 16:48 CET

Update

We have implemented a fix and see significant improvement. We will continue investigating the issue and monitor the situation closely.
Posted Mar 17, 2026 - 16:30 CET

Update

We are continuing to investigate this issue. Work is ongoing to resolve issues, and we are seeing signs of improvement.
Posted Mar 17, 2026 - 16:20 CET

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 16:12 CET

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 15:53 CET

Update

We are continuing to investigate the ongoing incident.

Signicat is treating this as an all-hands on deck situation, and we are giving it our highest priorities and resources.
Posted Mar 17, 2026 - 15:28 CET

Investigating

We might be experiencing issues and are currently investigating this issue.
Posted Mar 17, 2026 - 15:03 CET
This incident affected: Express Signature (Signature API), Dokobit by Signicat (Portal and Portal API), eID and Wallet Hub - eIDs (.beID, Buypass, DigiD, eHerkenning, Email OTP, Estonian ID Card, Finnish Bank eIDs (FTN), Freja eID, iDIN, itsme, MitID, MobileID (OIDC), mojeID, Norwegian BankID, Personalausweis, Samleikin, Smart-ID, SMS OTP, SPID, Swedish BankID, Suomi.fi e-identification), ID Document and Biometric Verification (Assure API), and OwnIdP, My Signicat, Signicat dashboard.