Incident on 3rd party service - Data Verification Source - Creditsafe

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 11:38 CET

Monitoring

The Basic and Roles endpoints are experiencing issues with source connectivity, and we’re currently looking into it. We expect this to be resolved by tomorrow morning (16/11).
Posted Nov 15, 2025 - 23:34 CET
This incident affected: Data Verification (Creditsafe).