Third party maintenance - FTN Ålandsbanken

Incident Report for Signicat

Resolved

The maintenance is completed
Posted Nov 17, 2025 - 04:00 CET

Monitoring

Ålandsbanken will conduct a planned system maintenance in their digital services.

Our eID connection towards this 3rd party service is running but might experience issues as a result of their maintenance.
Posted Nov 16, 2025 - 21:00 CET
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).