Third party maintenance - FTN OP

Incident Report for Signicat

Resolved

The scheduled maintenance has been completed.
Posted Oct 09, 2025 - 05:00 CEST

Update

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 23:00 CEST

Monitoring

Due to maintenance work, there could be occasional service breaks in OP's digital services and identification.

Our eID connection towards this 3rd party service is running but might experience issues as a result of their maintenance.
Posted Oct 08, 2025 - 22:00 CEST
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).