Degraded performance - Suomi.fi

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 14:17 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 13:46 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 03, 2025 - 13:34 CET

Investigating

We are currently observing degraded performance with suomi.fi, affecting integrations on api.signicat.com endpoints. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Nov 03, 2025 - 11:00 CET
This incident affected: eID Hub - eIDs (Suomi.fi e-identification).