Third party maintenance - FTN S-Bank

Incident Report for Signicat

Resolved

The maintenance has been completed
Posted Jun 04, 2026 - 06:00 CEST

Monitoring

Our eID connection towards this 3rd party service is running but might experience issues as a result of their maintenance.
Posted Jun 03, 2026 - 22:00 CEST
This incident affected: eID and Wallet Hub - eIDs (Finnish Bank eIDs (FTN)).