Issue with the long term QES

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted May 29, 2026 - 08:46 CEST

Identified

We are currently experiencing an issue with signing documents using long-term Qualified Electronic Signatures (QES). This has been reported to our third-party provider, who is actively investigating. We will provide updates as soon as we have more information.
Posted May 28, 2026 - 21:12 CEST
This incident affected: Global Solutions Identity Platform (Onboarding API - Signing) and Electronic Signing (SignatureID QES).