Incident on 3rd party service - FTN Spankki

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 14:38 CET

Update

We are seeing improvement but will continue to monitor.
Posted Mar 19, 2025 - 14:11 CET

Update

We are continuing to monitor for any further issues.
Posted Mar 19, 2025 - 13:43 CET

Monitoring

An incident is currently affecting FTN Spankki

Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.

We are monitoring their progression towards resolution.
Posted Mar 19, 2025 - 13:13 CET
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).