FTN Nordea bank instabilities
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted May 22, 2023 - 11:30 CEST
Identified
The issue appears to be related to a scheduled maintenance.
Posted May 22, 2023 - 10:19 CEST
Investigating
We are currently investigating this issue.
Posted May 22, 2023 - 10:18 CEST
This incident affected: Enterprise eID methods (Finnish Bank eIDs (FTN)).