Incident on 3rd party service - Assure API provider: Onfido

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:13 CEST

Update

A fix has been implemented for the issue.
We are continuing to monitor
Posted Oct 20, 2025 - 14:38 CEST

Monitoring

An incident is currently affecting Onfido with increased turnaround time for document check and processing in EU region.

Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.

We are monitoring their progression towards resolution.
Posted Oct 20, 2025 - 14:10 CEST
This incident affected: ID Document and Biometric Verification (eIDV Provider: Onfido).