Degraded performance - Sign v2. - Sign-UI

Incident Report for Signicat

Resolved

After investigating further, the issue have been identified to be a false alarm.
Posted Jun 02, 2026 - 10:25 CEST

Investigating

We are currently observing degraded performance with sign-ui, affecting integrations on api.signature.com. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Jun 02, 2026 - 10:17 CEST
This incident affected: Electronic Signing (Sign API v2).