Degraded performance - Data Verification source: Creditsafe

Incident Report for Signicat

Resolved

The incident has been resolved.
Posted Apr 14, 2026 - 10:07 CEST

Update

Parts of our source with Creditsafe is working, but service has not yet been fully restored.
We have identified the issue and is working towards an resolution.
Posted Apr 14, 2026 - 09:53 CEST

Identified

Parts of our source with Creditsafe is working, but service has not yet been fully restored.
We have identified the issue and is working towards an resolution.
Posted Apr 13, 2026 - 18:43 CEST

Update

We are continuing to monitor for any further issues.
Posted Apr 13, 2026 - 15:54 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 15:27 CEST

Investigating

We are currently observing degraded performance with Data Verification - Creditsafe, affecting integrations on api.signicat.com endpoints. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Apr 13, 2026 - 15:02 CEST
This incident affected: Data Verification (Creditsafe).