DigiD confirms they have maintenance from midnight to 6 AM UTC+1 (Amsterdam). This will affect DigiD in all forms. We expect service to be restored when their maintenance is completed.
Posted Nov 18, 2025 - 01:45 CET
Monitoring
An incident is currently affecting DigiD, DigiD app and possibly CombiConnect.
Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.
We are monitoring their progression towards resolution.
Posted Nov 18, 2025 - 00:48 CET
Update
Our initial investigation points toward an unscheduled maintenance or incident on 3rd party service DigID, also affecting DigID App and possibly DigID CombiConnect.
We will continue our investigation.
Posted Nov 18, 2025 - 00:32 CET
Investigating
We are currently experiencing degraded performance for DigID.
We are investigating the issue.
Posted Nov 18, 2025 - 00:22 CET
This incident affected: eID Hub - eIDs (DigiD, DigiD CombiConnect).