Reduced success rates for electronic signature services and MitID authentications
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 17:15 CEST
Update
Connection to Cloud HSM reestablished, we are seeing improvements on all affected services. We are continuing to monitor the situation.
Posted Apr 23, 2024 - 16:42 CEST
Update
We have implemented mitigating actions to workaround Cloud HSM dependency in packaging, and seeing positive results of packaging normalizing.
Posted Apr 23, 2024 - 16:16 CEST
Update
We are continuing to monitor the situation. Incident confirmed at Cloud HSM provider.
Posted Apr 23, 2024 - 15:54 CEST
Monitoring
We are still experiencing connectivity issues towards Cloud HSM. Incident identified to cause degraded performance on FTN transactions.
Posted Apr 23, 2024 - 15:39 CEST
Identified
We are currently experiencing connection issues towards our Cloud HSM provider, causing degraded performance on MitID transactions and packaging services.
Posted Apr 23, 2024 - 14:48 CEST
This incident affected: Enterprise Electronic Signatures (Sign API, PackagingService) and Enterprise eID methods (Finnish Bank eIDs (FTN), MitID).