FTN disturbance for Säästöbank customers
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 16:51 CEST
Identified
Säästöbank's identification service is currently experiencing a problem. Corrective measures are underway and we will notify you when the problem is over.
Posted Apr 23, 2024 - 16:32 CEST
This incident affected: Enterprise eID methods (Finnish Bank eIDs (FTN)).