Incident on 3rd party service - FTN Nordea

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 07:35 CEST

Update

We are continuing to monitor the situation and will provide a new update at 08:00 CEST
Posted Jun 24, 2025 - 23:57 CEST

Monitoring

An incident is currently affecting FTN Nordea
Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.
We are monitoring their progression towards resolution.
Posted Jun 24, 2025 - 22:31 CEST
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).