Incident on 3rd party service - Data Verification Source - Creditsafe

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:03 CET

Update

Our connection towards this 3rd party service is running but is not functioning properly as a result of their incident. We are continuing to monitor the situation.
Posted Nov 18, 2025 - 14:39 CET

Monitoring

We are currently experiencing issues towards our connection with Creditsafe and are currently looking into it.
Posted Nov 18, 2025 - 14:36 CET
This incident affected: Data Verification (Creditsafe).