Degraded performance - Document Service - Document management affected

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 13:29 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2026 - 09:00 CET

Update

We are continuing to work on a fix for this issue.

We expect to have a new update tomorrow at 09:00 CET.
Posted Mar 26, 2026 - 18:09 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 26, 2026 - 13:50 CET

Investigating

We are currently observing degraded performance with Document Service, affecting integrations on id.signicat.com endpoints. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.

Degraded performance for Documents (Legacy service) for a limited number of customers. Signing is working but management of these are affected.
Posted Mar 26, 2026 - 13:18 CET
This incident affected: Electronic Signing (DocumentService).