Degraded performance - iDIN-itsme

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 15:56 CEST

Investigating

We are currently observing degraded performance with iDIN-itsme. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Jun 11, 2026 - 14:05 CEST
This incident affected: eID and Wallet Hub - eIDs (iDIN).