Degraded performance - MitID Private for Business

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 16:27 CEST

Investigating

We are currently observing degraded performance with MitID Private for Business, affecting integrations on id.signciat.com and api.signicat.com endpoints. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Apr 10, 2026 - 00:01 CEST
This incident affected: eID and Wallet Hub - eIDs (MitID).