Incident on 3rd party service - MitID

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 12:12 CET

Monitoring

MitID has confirmed that they are investigating the issue.
We are monitoring their statuspage for updates.
Posted Feb 27, 2026 - 10:39 CET

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 10:30 CET
This incident affected: eID and Wallet Hub - eIDs (MitID).