Partial outage on FTN (Aktia)

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 10:32 CET

Monitoring

An incident is currently affecting FTN (Aktia).

We are currently implementing mitigation to restore functionality.
Posted Feb 25, 2026 - 08:11 CET
This incident affected: eID and Wallet Hub - eIDs (Finnish Bank eIDs (FTN)).