FTN OP maintenance downtime

Incident Report for Signicat

Resolved

Maintenance completed at 04:50 CEST
Posted Sep 23, 2023 - 11:16 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2023 - 23:36 CEST
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).