Incident on 3rd party service for VideoID

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:21 CET

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Nov 18, 2025 - 13:40 CET

Identified

We are continiuing monitoring their progression towards resolution.
Posted Nov 18, 2025 - 13:13 CET

Update

We are currently investigating an issue regarding degraded performance for VideoID due to our connection to CloudFlare not working properly
Posted Nov 18, 2025 - 12:51 CET

Investigating

We are currently investigating an issue regarding degraded performance for VideoID
Posted Nov 18, 2025 - 12:45 CET
This incident affected: ID Document and Biometric Verification (eIDV Provider: Signicat VideoID).