Incident on 3rd party service - FTN-Mobiilivarmenne

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 10:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 10:01 CEST

Investigating

We are currently observing degraded performance with FTN-Mobiilivarmenne. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Aug 18, 2025 - 09:35 CEST
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).