Reduced availability for Mobiilivarmenne
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 00:18 CET
Monitoring
The third-party provider has confirmed that some users may experience disruptions with the mobile authentication service
Posted Nov 13, 2024 - 19:00 CET
This incident affected: eID Hub - ID methods (Finnish Bank eIDs (FTN)).