Resolved
Services are restored.
Identified
Säästöpankki and OmaSp has extended the maintenance window to 18:00 CEST.
Identified
Säästöpankki and OmaSp is undergoing planned maintenance today until 14:00 CEST, causing a temporary full outage.
Investigating
An incident is currently affecting Säästöpankki
Our connection towards this 3rd party service is running but is not functioning properly as a result of their incident. We are monitoring their progression towards resolution.