Resolved
Incident resolved.
Monitoring
We see improved performance, we will continue monitoring.
Investigating
We are currently observing degraded performance with VideoID. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.