Resolved
The 3rd party incident is resolved.
Monitoring
We are continuing to monitor their progression towards resolution.
We will come back with an update tomorrow morning (16 June) at 09:00 CEST.
Monitoring
An incident is currently affecting Data Verification - KvK
Our connection towards this 3rd party service is running but is not functioning properly as a result of their incident.
We are monitoring their progression towards resolution.