Resolved
The issue has been identified and fix. The issue has been resolved.
Identified
We have identified the issue and is investigating an potential fix.
Investigating
We are currently investigating an potential issue affecting the shown transactions in the Signicat Dashboard.
Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.