No components marked as affected
Resolved
This incident has been resolved.
Monitoring
An incident was affecting itsme.
Our connection towards this 3rd party service was running but not functioning properly as a result of their incident.
Itsme reports that their services are up and running again, with downtime approximately 16:26-16:40 UTC+2 (Amsterdam).