Resolved
After investigating further, the issue have been identified to be a false alarm.
Investigating
We are currently observing degraded performance with sign-ui, affecting integrations on api.signature.com. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.