Resolved
This incident has been resolved.
Identified
We are currently observing degraded performance with Suomi.fi e-identification. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.