Resolved
This incident has been resolved.
Monitoring
We see improvement and services are restored. We will continue monitoring to see if systems are stable.
Investigating
We are seeing issues with several services. We are in touch with Google support, and they are investigating on their side.
Investigating
We are continuing to investigate this issue.
Investigating
We are continuing to investigate this issue.
Investigating
Investigating - We are currently observing degraded performance in our systems affecting services on DTP. Incident response has been initiated and we are working on determining if there is any impact.