itsme connectivity issues
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Jan 19, 2022 - 09:33 CET
Update
Itsme is still working on a fix for their issues.
Posted Jan 18, 2022 - 10:25 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 17, 2022 - 12:18 CET
Identified
Issues with itsme:

Since 11:15 (approx.) you may experience some slowness or connectivity problems with itsme® services.
We're investigating the cause and will provide an update as soon as we have more information available.

We apologize for the inconvenience.
Posted Jan 17, 2022 - 12:17 CET
This incident affected: Enterprise eID methods (itsme).